Fixing drush * needs a higher bootstrap level to run

Today while setting up a Drupal dev environment on a new PC I encountered the drush error "Command * needs a higher bootstrap level to run".
The first thing I did as many probably would is do a quick search on google. This though yields many different results and fixes. The problem though is I didn't know why it was happening so I didn't know which fix would work.
Turns out though it was quite easy to determine the actual problem. Drush has a nice option that will output dubug messages, funny enough, the option is --debug.
So, to get a better understanding of why you might be getting the "Command * needs a higher bootstrap level to run", simple enter this drush command: drush pm-list --debug and run through the output looking for what might be causing the problem.
In my case, I had a line that read "mysql is not recognised as an internal or external command", suggesting to me that my environment variable for mysql was not set up properly.

Add new comment

You must have Javascript enabled to use this form.